Version 8

8.9 - Numerous Fixes

  • Fixed - Program crash after hidding the layer dialog and selecting a new brush from the Brush Select dialog.
  • Fixed - Update the layer thumbnails in-sync with the main canvas.
  • Fixed - Update the layer dialog when loading pics, switches pages, new page, etc.
  • Fixed - Typo in the "Crop" warning dialog.
  • Fixed - Clicking and draging off the brush shortcuts could result in the Brush Select dialog coming up when it shouldn't.
  • Fixed - Don't change the ArtSet of a shortcut brush when it's merging it with another brush (color, shape, texture or effects)
  • Fixed - Don't change the brush options of a shortcut brush when it's merging it with another brush (color, shape, texture or effects)
  • Fixed - Some text in the preferences dialog was being cropped.

8.8 - Usability improvements, more special effects brushes and fixes.

  • Added - 18 new Process - Special Effects brushes.
  • Added - Layer mode "Adjustment Mask" to allow for more powerful composing.
  • Added - Brush effects "Shift x" and "Shift y" to move the brush dab along the x and y axis.
  • Changed - Layer window was made more narrow.
  • Changed - Layer window is now floating. It can remain open while you paint!
  • Changed - Adjustment to many dialogs so that the bottom buttons aren't cropped off.
  • Changed - Hotkey (Z) to (Alt + Z) to toggle ArtSet and Brush names in the brush shortcut panel.
  • Changed - Save ArtSet name in shortcut artset rather than separately so that it remains persistent.
  • Changed - The option for ArtSet names is now in the ArtSet menu and called "Toggle Shortcut Mode"
  • Changed - When the shortcuts are in ArtSet mode pick the original brush from the ArtSet rather than the shortcut. This has the effect of using the original default brush settings.
  • Enhanced - When the shortcuts are in ArtSet mode show the brush sample icon.
  • Enhanced - Hightlight the current brush in the Select Brush Dialog.
  • Enhanced - Recreated the default Shortcuts ArtSet so that the ArtSet name is stored and will default to the Essentials ArtSet when pulling up the Brush Selection dialog.
  • Fixed - The Blend Capture brush effect was mixing incorrectly resulting in colors on some brushes being dirty and moving towards black.
  • Fixed - Small improvement to the Bld_x brush effects to improve color mixing.
  • Fixed - Undo was not properly restoring 1 pixel along the right and bottom edges.
  • Fixed - Moving a layer with paper textures turned on resulted in reapplication of the paper texture. Paper textures should not be applied when moving a layer.

8.7

  • Fixed - ¬†Emergency fix to correct crash case on operations that change the size of the picture. Resize and crop.

8.6 - Undo system rewrite, new brushes, improved performance

  • Added - Preference to Keep Brush Colors. Toogles between the shortcut brushes retaining the last used settings (color, size etc) or using the defaults for the brush as selected from the ArtSet.
  • Added - Preference for number of undo levels 0 - 100. Found in the preferences dialog unto the edit menu.
  • Added - Process - Special Effects ArtSet. Includes around 30 brushes.
  • Added - Collections - Flowers ArtSet. Includes around 25 brushes.
  • Added - 9 new brushes to the Art Tools - Oil Paints set.
  • Added - Option in the Brush Select dialog (in edit mode) to create an icon for the selected brush from the current image. For good results draw your stroke on a page size of 200x100.
  • Improved - Completely rewrote the undo/redo system resulting in better memory usage and better performance for undos and redos.
  • Improved - Performance enhanced between strokes. Most noticeable on large canvases. Previously there was a lag between strokes limiting high speed sketching on large canvases.
  • Changed - Minor adjustment to license checking.
  • Fixed - Applying a filter would not enable the undo menu items.
  • Fixed - If a paper texture was selected during, crop, resize, rotates or image flips the texture was applied to the image layer as well as re-applied to the texture layer.

8.5 - Improved color picking, masks, copy and paste, page explorer and various other items.

  • Added - SaveAs option in the Edit ArtSet dialog.
  • Added - Color picking from Traced Image. If tracing mode is active the color picker will select colors from the traced picture.
  • Added - Color picking from just any layer - non-merged colors. Holding the Alt key and using the color picker will result in looking at each layer separately until a color is found (non-alpha)
  • Added - Ability to name books and pages in the Page Explorer.
  • Added - A menu bar in the Page Explorer.
  • Added - Brush options dialog is now available for the brushes in the brush shortcut banks. Use right click to access the brush options dialog.
  • Added - Masks are honored on Copy operations. Areas under the masked parts will not be copied.
  • Added - Paste as New. Menu option under Edit to paste your clipboard image as a new page.
  • Added - Effects - Basic ArtSet for an easier way to construct new brushes.
  • Improved - Color picker will now return the color that is visible (merged layer view) instead of the color on that layer. The color on just one layer can be returned by holding the ALT key when using the color picker.
  • Improved - Allow only one copy of TwistedBrush to run at a time.
  • Improved - Preserve original brush options when setting into the shortcut banks.
  • Improved - Paste will now paste the image data into a new layer. Use Paste as New or Paste Into for previous behavior.
  • Changed - In the Edit ArtSet dialog the Select button is now called Copy and doesn't select the brush but only copies the brush for placement in other ArtSets.
  • Changed - Don't show the license key in the about screen.
  • Changed - Removed hot keys in the Page Explorer. It confllicts with the edits areas that were added.
  • Fixed - Layers names were getting overwritten when selecting another layer in the layer dialog.
  • Fixed - Selecting a pattern brush with a different density but the same pattern would not make the scale adjustments.
  • Fixed - The currently edited brush settings were lost after going into the Select Brush dialog in edit mode.
  • Fixed - The ArtSet text edited in the Select Brush dialog was not saved when exiting the dialog.
  • Fixed - Typo in Quick Start screens.

8.4 - Additional layers, UI improvements, saving DPI and fixes.

  • Added - Save DPI setting when writing to JPG, PNG, TIF and BMP files.
  • Added - Support up to 32 layers now instead of just 16.
  • Added - Pattern Brushes can all now be scaled!! Use the density slider to change the scale of the pattern.
  • Added - Protection from trying to load a new version of a TBR file into a version of TB that doesn't support it.
  • Added - Allow the script brush tool to draw while dragging the mouse (with right mouse button down)
  • Added - Option to scale the Backgrounds filter. Found in the Filters menu.
  • Added - Hotkey (Z) to toggle ArtSet and Brush names in the brush shortcut panel.
  • Changed - When recording a script the current brush is not automatically recorded. This allows for scripts that can generically be used for any brush. To get the previous behavior just select a brush as your first step when recording a script.
  • Improved - Performance inproved in the layers dialog when scrolling and selecting layers.
  • Improved - Give warning if exiting the layer dialog with the current layer invisible.
  • Improved - Don't switch layers when setting the visibility or lock attribute in the layer dialog.
  • Fixed - When creating a new ArtSet the ArtSet name was always seen as ArtSet.
  • Fixed - Typo in sketchbook quick help page.
  • Fixed - When flattening an image (merging all layers) don't remove the texture surface layer (papers).
  • Fixed - When deleting a layer and then closing the layer dialog the main TwistedBrush screen wasn't almost on top most window on the screen.

8.3 - Quick Start Guide and minor fixes.

  • Added - Option for Showing ArtSet names in the brush slots rather than the brush names. The option is found in the menu Edit | Preferences
  • Added - Quick Start Guide
  • Improved - Center the selected layer in the layer dialog box when it opens up.
  • Fixed - When deleting a layer the, attributes of the delete layer were applied to the layer below it.
  • Fixed - ArtSet mapping to the brush slot was not being preserved between sessions.

8.2 - New Layer User Interface and various other improvements

  • Added - Filter Preview Off option. Turns off the default to have preview on for filters. Found in the menu Edit | Preferences.
  • Added - Brush Numbers option. Allows showing the brush numbers (1 - 60) in the select brush dialog. Turns this on from the menu Edit | Preferences.
  • Added - Hotkey "Y" to pull up the Layers dialog
  • Improved - New layer user interface with thumbnails for each layer.
  • Improved - Remember the ArtSet for each brush selection so that pulling up the brush selection dialog will default to the same ArtSet as the brush for that selection box.
  • Improved - All brush setting are returned to what they were prior to script playback
  • Improved - Deleting a layer will now select the next layer down rather than layer 1.
  • Improved - Merging a layer will now select the next layer down rather than layer 1.
  • Updated - Copyright year.
  • Changed - Layer Up and Layer Down now move layers in the opposite direction then before. It's more intuitive when looked at in the new layer interface.
  • Fixed - Brush options were not properly being saving when a new brush was added to an ArtSet.
  • Fixed - Script brushes were only playing back properly the first time.
  • Fixed - Setting the clone/trace source was failing if the page had not been saved yet.

8.1 - Major Brush Selection and ArtSet Usage Improvements

  • Improved - Major changed to how brushes and ArtSets are selected and used.
  • Changed - ArtSet menu items for optimize ArtSet, Select Brush, Select Brush List and Select ArtSet are no longer needed.
  • Changed - The ArtSet panel is replaced by a panel of current brushes of which 54 are remembered as shortcuts in 6 banks of 9 brushes each.
  • Changed - The brush shortcut keys are replaced by the key brush shortcut system where pressing the keys 1 - 9 will select that shortcut brush.
  • Changed - Setting the shortcut brush is now supported with a full UI and no longer requres holding down the number keys.
  • Changed - The concept of loading ArtSets is completely gone. Brushes are selected from the entire array of ArtSets and are stored in the brush Shortcuts area.
  • Changed - The Load ArtSet, Save ArtSet and Saveas ArtSet from the File menu are removed.
  • Changed - The Brush Selection dialog is completely redone, showing the text of every brush in the ArtSet and a brush sample.
  • Changed - The Brush Selection List dialog is complete gone.
  • Changed - Editing ArtSets is unified into the Brush Select dialog when envoked in edit mode which is done from the ArtSet | Edit ArtSet menu.
  • Changed - The concept of a locked ArtSet is no longer used since editing an ArtSet is done via special menu.
  • Changed -The concept of an ArtSet name is removed and the file name is used also as the ArtSet name.
  • Changed - Selecting a Shape, texture, or any brush that doesn't store the primary brush information will only update the current brush. Previously had to hold the Ctrl key to force a merge.
  • Changed - Brush sample pictures are moved with the brushes within ArtSets.
  • Changed - The History - Brush and History - Color ArtSet now appear in the brush selection dialog.
  • Changed - The History - Brush and History - Color ArtSet now store the brush sample picture along with the brush.
  • Changed - Updated the "Set as Clone Source" to read "Set as Clone/Tracing Source"
  • Changed - Wording and position of File menus, Save, Import Image and Export Image.

8.0 - EYEeffects Color Palletes (59 total new color palettes)!

  • Added - 59 Color Palettes contributed by Shayne of EYEeffects!!!
  • Added - The original Oil Paints ArtSet back into the distribution. While the new Oil Paints ArtSet released in 7.9 is generally more realistic this artset has a different feel on some brushes that aren't available elsewhere.
  • Added - Import and Export Brush String Code. A way to share brush settings as a block of text characters.
  • Added - Brush Effects - Spray 1, Spray 2 and Spray 3 with values of 5 and 10.
  • Added - Numerous brush icons.
  • Added - 5 additional brushes to the Palette Knife ArtSet.
  • Added - Palette menu managing color palettes.
  • Added - Commands to create a color palette based on 1, 2, 3 or 4 colors. In the Palette menu.
  • Added - Command to clear the current color palette. In the Palette menu.
  • Added - Command to reset all the color palettes back to the original state. In the Palette menu.
  • Added - Ability to keep 8 color palettes loaded at once and switched with the tabs below the palettes (Pal1...Pal8).
  • Added - 7 New Pixarra color palettes. Spectrum 02, Spectum 03, RGB White, RGB Black, Red Scale, Green Scale, Blue Scale and Artist Paints.
  • Added - Fine Tune Settings for size, density, opacity, red, green or blue values. Right click on sliders.
  • Added - Right clicking on the ArtSet tab will bring up the load ArtSet Dialog. (same for color palette tabs)
  • Added - Color palette preview in the Load Palette dialog.
  • Added - ArtSet - Collections - User Brushes. A repository for user contributed brushes.
  • Changed - Reorganized the Essentials ArtSe and added in some new improved brushes.
  • Changed - Slightly darken unselected ArtSet and Color Palette tabs.
  • Changed - Look of selected ArtSet and selected Brush name areas and allow clicking anywhere in the name bar to bring up the select ArtSet or select Brush dialogs.
  • Fixed - Spelling error in Preferences dialog.